Frequently Asked Questions

What are the c-Site system requirements?

Last Updated: July 31, 2006 8:38 AM

c-Site is compatible with the following browser versions:

  • Internet Explorer 5.0 or higher
  • Netscape Navigator 7.0 or higher
  • Mozilla Firefox, all versions
  • Opera 7.5 or higher

c-Site is not not compatible with the following browser versions:

  • Safari
  • Internet Explorer on Macintosh