Frequently Asked Questions

What are the system requirements for Online Group Calendar?

Last Updated: May 10, 2007 3:13 PM

The supported browsers are:

  • Windows Internet Explorer 6.0 and later
  • Mozilla Firefox 1.0 and later
  • Safari 1.3 and later
  • Netscape 8.0 and later
  • Mozilla 5.0 and later